46. Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к переполнению (т.е. к результату большему чем 32 767). Если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел. Через Дельфи

Program Name;
uses crt;
Var
a, b, s :integer;
Begin
Write(введите a );
readln(a);
Write(введите b );
readln(b);
S:=a+b;
if s<32767 then
writeln(s)
else
writeln(произошло переполнение);
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку