С клавиатуры вводится произвольная строка, состоящая из символов латинского алфавита. Группы символов, раздельные пробелами, и не имеющие пробелов внутри будем называть словами. Напишите программу, которая заменяет каждое слово строки на его длину. Длина строки не более 100 символов.
Например: Исходная строка: "An example of a string of characters "
Преобразованная строка "2 7 2 1 2 10"

Pascal

 var   
s : string;   
i,k : integer; 
begin 
readln (s); 
k := 0; 
for i := 1 to Length(s) do   
begin   
if s[i] <> then     
k := k + 1   
else     
begin     
write (k+s[i]);     
 k := 0;   
end;   
end; 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку