Даны натуральное число n, целые числа a1,a2,a3...,an. найти количество и суммы тех членов данной последовательности, которые делятся на 5 и не делятся на 7
Прошу написать программу в Паскале

Const
  nn=100; { максимальное значение n }
var
  i,n,k,s:integer;
  a:array[1..nn] of integer;
begin
  Write(Укажите натуральное число n: ); Read(n);
  Randomize;
  k:=0; s:=0;
  Writeln(Сформированная последовательность);
  for i:=1 to n do begin
    a[i]:=Random(99)+1; { случайное число на интервале [1;99] }
    Write(a[i]:3);
    if (a[i] mod 5=0) and (a[i] mod 7 <>0) then
      begin Inc(k); s:=s+a[i] end;
  end;
  Writeln;
  Writeln(Количество чисел, кратных пяти: ,k);
  Writeln(их сумма равна ,s)
end.

Тестовое решение:
Укажите натуральное число n: 39
Сформированная последовательность
 15 83 69 64 56 50 13 70 55 40 22 82 45 67 31 36 16 52 67 44 63 23 52 62 89 33 40 32 17 14 98 15  5 58 46 68 57 72 90
Количество чисел, кратных пяти: 9
их сумма равна 355

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку