Составьте программу вычисления количества трёхзначных чисел, у которых цифры упорядочены строго по возрастанию

 Program Pr;

var a:array[100..999] of integer;

q,w,v,c,i,d:integer;

 

Begin

n:=-1;

c:=1;

For i:=1 to 899 do begin

a[i]:=99+c;

c:=c+1;

q:=a[i] mod 10;

a[i]:=a[i] div 10;

w:=a[i] mod 10;

a[i]:=a[i] div 10;

if (q>w) and (q>a[i]) and (w>a[i]) then v:=v+1;

end;

writeln(Всего этих числел=,v);

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×