. Составить программу на языке «Рascal» для вычисления значений функции:
3sinx+8, если х<π/2
y=
4cos2x , если x≥π/2
при 0≤x≤π с шагом h= π/10

y=begin {cases} displaystyle 3sin(x)+8, quad x textless   frac{pi}{2}   displaystyle 4cos(2x), quad xgeqslant  frac{pi}{2} end {cases}

uses Crt;
const
  Pi=3.14159265;
var
  x,y:real;
begin
  ClrScr;
  x:=0;
  while x<=Pi do begin
    if x    else y:=4*cos(2*x);
    Writeln(x=,x:8:5,,  y=,y:8:5);
    x:=x+Pi/10
  end;
  ReadKey
end.

Тестовое решение:
x= 0.00000,  y= 8.00000
x= 0.31416,  y= 8.92705
x= 0.62832,  y= 9.76336
x= 0.94248,  y=10.42705
x= 1.25664,  y=10.85317
x= 1.57080,  y=-4.00000
x= 1.88496,  y=-3.23607
x= 2.19911,  y=-1.23607
x= 2.51327,  y= 1.23607
x= 2.82743,  y= 3.23607
x= 3.14159,  y= 4.00000

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку