На соревнованиях выступление спортсмена оценивают 5 экспертов, каждый из них выставляет оценку в баллах (целое число). Для получения итоговой оценки лучшая и худшая из оценок экспертов отбрасываются, а для оставшихся трёх находится среднее арифметическое. Напишите программу, которая принимает 5 оценок экспертов и возвращает итоговую оценку спортсмена. Используйте функцию для вычисления итоговой оценки. ПАСКАЛЬ
Const
n=5;
var
m:array[1..n] of byte;
function Itog():real;
var
i,max,min,s:byte;
begin
s:=m[1]; max:=s; min:=s;
for i:=2 to n do begin
s:=s+m[i];
if max
if min>m[i] then min:=m[i]
end;
s:=s-max-min;
Itog:=s/(n-2)
end;
var
i:byte;
begin
Writeln(Введите экспертные оценки);
for i:=1 to n do Read(m[i]);
Writeln(Итоговый балл равен ,Itog:4:2)
end.
Тестовое решение:
Введите экспертные оценки
4 4 5 3 5
Итоговый балл равен 4.33
Оцени ответ
