Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N ! = 1·2·{...}· N .
Входные данные
Входная строка содержит одно натуральное число N .
Выходные данные
Программа должна вывести одно число – факториал введённого числа N .
Program pr;
var i,x,a:longint;
begin
readln(a);
x:=1;
for i:=2 to a do
x:=x*i;
writeln(x);
end.
Оцени ответ
