Составить программу на языке Паскаль для вычисления и печати таблицы значений функции Y=sin2(x-1)+2cos((x-1)/2), при условии, что X0=0.3, Xк=1.7, DX=0.2.

// PascalABC.Net v2.2 build 1019
program znanija_12709887;

const  
  xMin = 0.3; 
  xMax = 1.7;   
  xStep = 0.2;
var  
  y : real; 
  x : real;
begin 
  x := xMin; 
  while x <= xMax do begin   
    y := sin(2)*(x - 1) + 2 * cos((x - 1) / 2);   
    writeln (x = , x, y = , y);   
    x := x + xStep; 
  end;  
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку