Дано четырехзначное число. Написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа.
program a1;
var
a,b,c,r:byte; l,k:word;
begin
read(l);
a:=l mod 10;
b:=l div 10 mod 10;
c:= l div 100 mod 10;
r:= l div 1000 mod 10;
k:=c*1000+r*100+a*10+b;
write(k); end.
Оцени ответ
