Битовый код для точки с координатами ( x , y ) состоит из четырех битов, каждый из которых показывает, входит ли точка в одну из заштрихованных областей. Первый по счёту бит определяет, входит ли точка в область а (см. рисунок), второй третий и четвёртый биты отвечают за попадание точки соответственно в области б , в и г . Напишите программу, которая выводит битовый код точки с заданными координатами.

Var x,y: real;
var a,b,c,d:integer;
begin
readln(x,y);
if (y<1) then
write (1)     
   else write (0);
if (y<-x) then
 write (1)   
      else write (0);
if sqr(x)+sqr(y)<1 then
 write (1)   
         else write (0);
if sqr(x-1)+sqr(y)<1 then
  write (1)                     
else write (0);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку