Напишите программу на паскале определения суммы цифр числа. Укажите является ли полученный результат четным числом.

var

  a, c : integer;

begin

  read (a);

  c := 0;

  while a > 0 do

  begin

    c := c + a mod 10;

    a := a div 10;

  end;

  writeln (c);

  if c mod 2 = 0 then write (Четное) else write (Нечетное);

end.

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку