Составить программу вычисления суммы цифр двухзначного числа "a".Значение "а",введите с клавиатуры.ПОМОГИТЕ!!!Срочно надо(Буду вам очень признательна *_*

Должно работать и для двухзначного и для 3ехзначного и для 99999значного
var
a,sum:integer;
begin
readln(a);
while a>0 do
begin
sum:=sum+a mod 10;
a:=a div  10;
end;
writeln(sum);
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку