1) написать программу, вычисления значений функции Y=1/X+2 с шагом 0,1. значения аргумента беруться из [-1;1]... 2) заполнить таблицу значений функции y=sqrt(1/2x-1)+2 c шагом 0,1. значения аргумента беруться из [0;3,8]. предстоит продумать вопрос вывода результата... найти значение x, при котором функция не определена..
program P1;
uses
crt;
var
x,y : real;
begin
clrscr;
x := -1;
writeln(----------);
while x <= 1 do
begin
y := 1/x+2;
x := x + 0.1;
writeln(y);
end;
writeln(----------);
writeln();
x := 0;
writeln(----------);
while x <= 3.8 do
begin
if (x <> 0) and (1/(2*x)-1 >= 0) then
y := sqrt(1/(2*x)-1)+2 else
writeln(Pri X = ,x, ne opredelena);
x := x + 0.1;
writeln(y);
end;
writeln(----------);
readln;
readln;
end.
Оцени ответ
