Вася изготовил карточки, написав на них N первых заглавных букв латинского алфавита. Карточки Вася положил в стопку. Дальше он берет первую сверху карточку и кладет ее в новую стопку. Далее вторую карточку он кладет вниз этой новой стопки, третью — наверх новой стопки, потом четвертую — опять вниз, следующую — наверх и т.д. После этого оказалось, что карточки лежат строго по алфавиту, если просматривать их сверху вниз. Напишите программу, которая выведет, в каком порядке карточки лежали в исходной стопке. Входные данные. Вводится натуральное число N (N не превышает 26). Выходные данные. Выведите буквы, написанные на карточках в исходной стопке, если ее просматривать сверху вниз (должны быть выведены заглавные латинские буквы без пробелов между ними).

Program z1;
const s=ABCDEFGHIJKLMNOPQRSTUVWXYZ;
var 
t: string;
n,i,j: integer;
begin
writeln(Введите количество карточек);
readln(n);
if odd(n) then
i:=(n+1) div 2
else i:=n div 2;
j:=i+1;
t:=;
repeat t:=t+s[i]+s[j];
i:=i-1;
j:=j+1;
until i=0;
writeln(copy(t,1,n))
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку