Два игрока A и B бросают кубик и суммируют результаты бросков. Победителем объявляется игрок, набравший первым объявленную сумму очков S. Напишите программу, определяющую победителя
Var A,B:byte;
S,Sa,Sb:integer;
Begin
WriteLn(S = );ReadLn(S);
Repeat
Write(A = );ReadLn(A);
Sa:=Sa+A;
Write(B = );ReadLn(B);
Sb:=Sb+B;
Until (Sa>=S)or(Sb>=S);
if (A>B) then WriteLn(Победил игрок A)
else WriteLn(Победил игрок B)
End.
Оцени ответ
