Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными (паскаль авс)
UPD
__________
Var
a,b,s,i:integer;
begin
readln(a,b);
if a <> b then
for i:=1 to abs(b) do s:=s+a
else for I:=1 to abs(b) do s:=s+a;
if (a<0) and (b<0) then s:=abs(s)
else if b<0 then s:=-s;
writeln(s);
end.
Оцени ответ
