Найти все двузначные числа, которые делятся на n и содержат в себе цифру n
P.S. написать программу в Паскале через цикл while

Var
A,N,C:byte;
B:boolean;
Begin
B:=false;
Write(N = );ReadLn(N);
A:=10;
While A<100 do
Begin
if A mod N = 0 then
 Begin
 C:=A;
 While C<>0 do
  Begin
  if C mod 10 = N then B:=true;
  C:=C div 10
  End;
 if B then Write(A, );
 B:=false
 End;
A:=A+1
End
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку