Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К
сожалению, проспать 14 часов ему не удалось, т.к. будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит.
Ооочень уж больно знакомая задачка ))) решаю с файлами - так как во всех случаях обычно она даётся на решение с файлами))
var s,t:integer;
begin
assign(input,input.txt);
reset(input);
assign(output,output.txt);
rewrite(output);
read(s,t);
if s<=t then writeln(t-s) else writeln (t+12-s);
close(output );
end.
___________________________
та же задача б то же решение токо без файлов))
var s,t:integer;
begin
writeln(s=);
readln(s);
writeln(t=);
readln(t);
if s<=t then writeln(t-s) else writeln (t+12-s);
readln;
end.
_______________________
УСПЕХОВ :)
Оцени ответ
