Написать программу на паскале, которая вычислит точки пересечения двух функций.
ax^2 +bx+c=y
y=kx+q*
ax^2 + bx + c = kx + q
ax^2 + (b - k) x + (c - q) = 0
var
a, b, x, k, q, D : real;
begin
read (a, b, x, k, q);
D := sqr ((b - k)) - 4 * a * (c - q);
if D < 0 then writeln (Нет перечечений)
else
begin
writeln (((k - b) + sqrt (D)) / (2 * a));
writeln (((k - b) - sqrt (D)) / (2 * a));
end;
end.
Оцени ответ
