На соревнованиях выступление спортсмена оценивают 5 экспертов, каждый из них выставляет оценку в баллах (целое число). Для получения итоговой оценки лучшая и худшая из оценок экспертов отбрасываются, а для оставшихся трёх находится среднее арифметическое. Напишите программу, которая принимает 5 оценок экспертов и возвращает итоговую оценку спортсмена. Используйте функцию для вычисления итоговой оценки.
Входные данные
Входная строка содержит 5 неотрицательных целых чисел, разделённых пробелами.
Выходные данные
Программа должна вывести в первой строке отброшенные оценки экспертов (минимальную, затем максимальную), разделив их пробелами. Во второй строке выводится одно вещественное число: итоговая оценка с двумя знаками в дробной части. Pascal
Var
A:array of integer;
i:integer;
Function Free(A:array of integer):real;
Var i:integer;
Begin
For i:= 2 to 5 do
if A[i]For i:= 1 to 4 do
if A[i]>A[A[6]] then A[6]:=i;
WriteLn(A[A[0]], ,A[A[6]]);
For i:= 1 to 5 do
if (i<>A[0])and(i<>A[6]) then Free:=Free+A[i];
WriteLn((Free/3):0:2)
End;
Begin
SetLength(A,7);
For i:= 1 to 5 do
Read(A[i]);
A[0]:=1;
A[6]:=5;
Free(A);
End.
Оцени ответ
