Дан массив из 20 действительных чисел. Напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты. Желательно подробную программу, буду всем благодарна)

Var A:array[1..20]of real;
B,C:real;
i:byte;
Begin
WriteLn(Введи элементы массива через пробел);
For i:= 1 to 20 do
 Read(A[i]);
For i:= 1 to 20 do
 if A[i]>0 then B:=B+A[i]
 else C:=C+A[i];
WriteLn(Сумма положительных элементов = ,B);
WriteLn(Сумма отрицательных = ,C)
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку