напишите программу которая производит обмен значений переменных х и у если х больше у
Если не использовать дополнительных переменных(для чисел),то:
Var x,y:integer;
begin
read(x,y);
x:=x+y;
y:=x-y;
x:=x-y;
writeln(x, ,y);
end.
Можно и через дополнительную переменную:
Var x,y,s:integer;
begin
read(x,y);
s:=x;
x:=y;
y:=s;
writeln(x, ,y);
end.
Оцени ответ
