написать программу вывода на экран всех трехзначных чисел, кратных и 6, и 4, и заканчивающихся на цифру 8. Программу написать темя способами с использованием циклов For, While, Repeat.
ПОЖАЛУЙСТА! ОЧЕНЬ СРОЧНО!
Var i:integer;
begin
for i:=100 to 999 do if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, );
end.
{While}
Var i:integer;
begin
i:=100;
while i<=999 do begin
if( if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ); inc(i); end;
end.
{Repeat}
Var i:integer;
begin
i:=100;
repeat
begin
if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, );
inc(i); end;
until i<1000;
end.
Оцени ответ
