составить на Паскале:

1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры.

2) одноклеточная амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)

1)

var

  s : real;

  i, n : integer;

begin

  s := 0;

  read (n);

  for i := 1 to n do s := s + 1 / i;

  writeln (s);

end.

 

2)

var

  a, i : integer;

begin

  a := 1;

  for i := 1 to 8 do

  begin

    a := a * 2;

    writeln (Через , i * 3, часов будет , a, амеб);

  end;

end.

 

3)

var

  n, i : integer;

  x, s : real;

begin

  s := 0;

  read (n, x);

  for i := 1 to n do

    s := s + sin (i * x);

  writeln (s);

end.

 

4)

var

  n, a, r, i : integer;

begin

  r := 1;

  read (a, n);

  for i := 1 to n do r := r * a;

  writeln (r);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку