Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен ноль) и подсчет суммы и среднего арифметического введенных положительных чисел. Используйте оператор repeat.

var
   date, number, summa : integer;
   avarage : real;
begin
   date := 1;
   summa := 0;
   number := 0;
   avarage := 0;
   repeat
      readln(date);
      if (date <> 0) then
         begin
            number := number + 1;
         end;
      summa := summa + date;
   until (date = 0);
   avarage := summa / number;   writeln(Summa = , summa);
   writeln(Srednee znachenie = , avarage:2:3);
   readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку