Написать программу, которая определяет, попадет ли точка с заданными координатами в область, закрашенную на рисунку серым цветом. Результат работы программы вывести в виде текстового сообщения.( На языке C#)

using System;

class Program
{
    static void Main(string[] args)
     {
         const float radius = 5f;
          float x = float.Parse(Console.ReadLine());
          Console.Write("y: ");
           float y = float.Parse(Console.ReadLine());
           Console.WriteLine((x > radius || x < -radius || y > radius || y < -radius |
             ((x - -radius) * (x - -radius) + (y - radius) * (y - radius)) < radius ||
             ((x - radius) * (x - radius) + (y - -radius) * (y - -radius)) < radius) ? "Out" : "In");
           Console.ReadKey(true);
      }
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку