Ваня наблюдает за лягушкой. Изначально она сидит в точке 0 числовой прямой. Каждую секунду
она прыгает на 1 вправо, пока не достигнет точки K .Затем она начинает каждую секунду прыгать на 1
влево, пока не вернется в точку 0,затем – опять вправо и т.д. Требуется определить, где окажется лягушка через T секунд.
Формат входных данных
Во входном файле input.txt в двух строках находятся два числа K и T, разделенные пробелом. Оба
числа натуральные и не превосходят 1 000 000 000.
Формат выходных данных
Вывести в выходной файл output.txt одно число – координату лягушки в момент времени T.
Пример
Пример входного файла input.txt Пример выходного файла output.txt
5
8 2
Примечание
Программа не должна выводить никаких дополнительных сообщений, а также не может содержать
операторов, вызывающих задержку выполнения программы (например, readln в конце программы)

Var
 a,b,c,d,i,j,l:longint;
begin
 assign(input,input.txt);
 reset(input);
 assign(output,output.txt);
 rewrite(output);
 readln(a,b);
 c:=b mod a;
 if odd(b div a) then writeln(a-c) else writeln(c);
end.
Если не работает напиши .

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку