Помогите пожалуйста решить задачу!
Задача A. Гулливер
Из книги Джонатана Свифта мы знаем, что тот Гулливер посетил страну «Лилипутию», где живут лилипуты, окруженные вещами, животными и заводами небольшого размера. Сначала лилипуты боялись Гулливера, но позже они поняли, что такое соседство приносит им большую выгоду, и они стали помогать ему. Например, лилипуты делали кровать для Гулливера из своих маленьких матрацев, сшитых вместе. Лилипутам были известны размеры Гулливера. Довольно быстро они смогли просчитать количество матрацев, необходимых для шитья большого матраца. Но у них постоянно возникали сложности с их небольшим ростом и стеля постель, они иногда не могли сшить достаточно толстый матрац.
Входные данные
Входной файл INPUT.TXT содержит два целых числа, которые разделены пробелом: K – коэффициент, отражающий во сколько раз Гулливер больше лилипутов, и M – количество слоев матрацев (2 <= K, M <= 100).
Выходные данные
В выходной файл OUTPUT.TXT выведите количество матрацев лилипутов, необходимых для построения матраца для Гулливера.
Задача очень простая
у нас есть два значения коэффициент, отражающий во сколько раз Гулливер больше лилипутов, и M – количество слоев матрацев ...
на выходе пусть у нас будет значение х-количество матрацев лилипутов, необходимых для построения матраца для Гулливера....
чтоб было понятней обозначим площадь лилипута Ал и площадь гуливера Аг
тогда х= (Аг/Ал)*М
Аг/Ал=К
тогда х=К*М ..теперь сделаем прогу
var К,М :integer;
begin
assign (input,input.txt);
reser(input);
assign(output,output.txt);
rewrite (output);
read(К,М);
writeln (К*М);
close (output);
end.
Оцени ответ
