СРОЧНО!!!!требуется определить делимость на 7 натурального числа записанного в двоичной системе счисления.
Формат входных данных: в первой строке входного файла INPUT.TXT содержится двоичное число в котором не более 30 цифр.
формат выходных данных: выходной файл OUTPUT.TXT должен содержать двоичное число-результат деления данного числа на 7 если данное число кратно 7 или 0 в противном случае.

Program Turashova_Anna;

Const  V: String = 01;  
Function DecToN(A: Longint; D: Byte) : String; 
Begin  If A > D - 1  
then DecToN := DecToN(A div D, D) + V[(A mod D) + 1] 
else DecToN := V [A + 1]; 
end;    

Function NToDec(A: String; D: Byte): Longint;   
Begin   
If Length(a) > 0    
then NToDec := Pos(A [Length(A)], V) - 1 + D * NToDec(Copy (A, 1, Length(A) - 1), D)   
else NToDec := 0;   
end;

Var F: String;     
Begin     
Write(Входной файл Input.txt: ); Readln(F); 
If NToDec(F,2)      
mod 7 = 0      
then Writeln(Выходной файл Output.txt: 0,DecToN(NToDec(F,2) div 7,2))      
else Writeln(Выходной файл Output.txt: 0);     
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×