Передавая записку на уроке английского языка, друзья не хотят, чтобы кто-то прочел ее содержимое. Для этого текст шифруют простым методом: заменяют каждую букву на букву, расположенную в алфавите на расстоянии N символов от исходной. Считается, что алфавит циклически замкнут. Напишите программу-шифровальщик.

Const
  N = 5;
  EN = abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ;
  RU = абвгдеёжзийклмнопрстуфхцчшщьыъэюяАБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЬЫЪЭЮЯ;
Var
  S : String;
  i : Byte;
Begin
  Readln(S);
  For i:=1 to Length(S) do
  Begin
    If Pos(S[i],EN)>0 then
      If Pos(S[i],EN)+N<=Length(EN) then
        S[i]:=EN[Pos(S[i],EN)+N] else S[i]:=EN[Pos(S[i],EN)+N-Length(EN)];
    If Pos(S[i],RU)>0 then
      If Pos(S[i],RU)+N<=Length(RU) then
        S[i]:=RU[Pos(S[i],RU)+N] else S[i]:=RU[Pos(S[i],RU)+N-Length(RU)];
  end;
  Writeln(S);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку