Составьте программу, которая выводит на экран различные приветствия в зависимости от введенного времени. Договоримся, что утро длится с 8 до 12 часов, день – с 12 до 17 часов, вечер – с 17 до 23 часов и ночь – все остальное время.
PROGRAM Privet;
VAR x:real;
BEGIN
writeln(Который час?); read(x);
if ____________________ then writeln(Доброе утро!);
if ____________________ then writeln(Добрый день!);
if ____________________ then writeln(Добрый вечер!);
if ____________________ then writeln(Доброй ночи!)
else writeln(Введенное число не является временем ) ;
END.
PROGRAM
Privet;
VAR
x:
real;
BEGIN
writeln(
Который час?); read(x);
if
x>
24 then
writeln(
Введенное число не является временем )
else
begin
if
(x>=
8) and (x<12) then writeln(Доброе утро!);
if
(x>=
12) and (x<17) then writeln(Добрый день!);
if
(x>=
17) and (x<23) then writeln(Добрый вечер!);
if
(x>=
23) or (x<8) then writeln(Доброй ночи!);
end
;
end
.
