Решите в тетради задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры
begin
read(n);
while (n <> 0) do // пока не равно нулю делать
begin
s := s + n;
k = k + 1;
end.
writeln(s/k); // среднее
writeln(s); // сумма
end.
Переменные сам объяви. s и к должны быть типа real
Если что-то не понятно пиши в ЛС
Оцени ответ
