Штирлиц поручил радистке Кэт подобрать чемодан для перевозки рации. Чемодан и рация имеют форму параллелепипеда. Рацию можно класть в чемодан только вертикально или горизонтально (рацию нельзя ставить под углом к дну чемодана). Боковые стенки рации должны быть параллельны боковым стенкам чемодана. Рация НЕ может поместиться в чемодане, если при этом какой–либо из ее размеров больше или равен соответствующему размеру чемодана. Ниже на рисунке приведены примеры неправильного и правильного размещения рации в чемодане. Напишите программу, которая подскажет радистке Кэт, поместится ли рация в чемодане.
Входные данные
В первой строке входных данных записано три числа – размеры рации в сантиметрах, а во второй – размеры чемодана в сантиметрах. Все числа целые положительные и не превосходят 100.
Выходные данные
В выходных данных требуется записать строку ПОМЕЩАЕТСЯ, если рация помещается в чемодане, или строку НЕ ПОМЕЩАЕТСЯ в противном случае.

Var x,y,z,x1,y1,z1:integer;
begin
write(введите высоту рации=>);
readln(x);
write(введите высоту рации=>);
readln(y);
write(введите высоту рации=>);
readln(z);
write(введите высоту чемодана=>);
readln(x1);
write(введите высоту чемодана=>);
readln(y1);
write(введите высоту чемодана=>);
readln(z1);
if ((x else writeln(НЕ ПОМЕЩАЕТСЯ);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку