Дан массив из десяти целых чисел . определите, сколько элементов этого массива имеют максимальное значение. паскаль

Var
  a: array[1..10] of integer;
  m, i,s: integer;

begin
  randomize;
  for i := 1 to 10 do 
  begin
    a[i] := random(+10) + 1;
    if a[i] > m then m := a[i];
  end;
  for i := 1 to 10 do 
  begin
    if a[i]=m then s:=s+1;
  end;
  writeln(s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку