Написать программу, которая считывает два числа a и б, и выдает Б-тую цифру числа А! Например: число 192345(А)
Число Б = 3, тогда третяя цифра в числе 192345 равняется 2
#include
int main()
{
int a,b,e,d;
a=192345; //Число
e=5; //Номер цифры
int c[1000000];
d=0;
while(a>0)
{
b=a%10;
d++;
c[d]=b;
a/=10;
}
for(int i=d;i>0;i--){
if((d-i+1)==e)printf("Цифра %dn",c[i]); //Вывод искомой цифры
}
return 0;
}
Оцени ответ
