Задача.Чиновник, ежемесячно берёт взятки в размере Х рублей. Величина Х непостоянная и колеблется от 0 до 150000 рублей. Автомобиль BMW 3, который хочет купить на взятки чиновник, стоит 1700000 рублей. Напишите программу, которая вычислит, сколько месяцев потребуется чиновнику на сбор нужной суммы.Подумать как решить. Используется оператор random. Прочесть в интернете о его применении.
Написать программу в поскале!
заранее спасибо
//PascalABC.Net 3.0, сборка 1053
const
BMW=1700000;
var
s,x:longint;
n:byte;
begin
Randomize;
n:=0; s:=0;
Writeln(Месяц Сумма взятки Накоплено);
while s
Writeln(n:4,x:12,s:15)
end;
Writeln(Потребуется месяцев: ,n)
end.
Тестовое решение:
Месяц Сумма взятки Накоплено
1 131598 131598
2 40502 172100
3 90384 262484
4 33945 296429
5 50956 347385
6 137449 484834
7 32050 516884
8 68439 585323
9 1187 586510
10 70707 657217
11 145871 803088
12 143780 946868
13 54179 1001047
14 39314 1040361
15 30297 1070658
16 49163 1119821
17 63244 1183065
18 128362 1311427
19 87284 1398711
20 80851 1479562
21 71269 1550831
22 139577 1690408
23 78690 1769098
Потребуется месяцев: 23
