Создайте рекурсивную функцию для вычисления неизвестного следующей последовательности. Напишите программу ее проверки. Проверять корректность исходных данных в работе не требуется. Замечание: рекурсивное решение в данном случае не оптимально; задание предназначено только для того, чтобы попробовать сделать простейшую рекурсивную функцию. Ниже на скрине красным веделено...
PASCAL(Lazarus)
помогите пожалуйста!! Не понимаю, как сделать....
Желательно с кодом.. Спасибо
//PascalABC.Net 3.0, сборка 1053
function F(n:integer):longint;
begin
case n of
1: F:=4;
2: F:=-4;
else F:=6*F(n-1)-4*F(n-2)
end
end;
begin
Writeln(F(5)=,F(5)) { тестовое}
end.
Тестовое решение:
F(5)=-1184
Оцени ответ
