Напишите программу, которая строит последовательность из N случайных чисел на отрезке от 0 до 1 и определяет, сколько из них попадает в полуинтервалы [0; 0,25], [0,25;0,5), [0,5; 0,75) и [0,75;1). Сравните результаты, полученные при N=10,100, 1000, 10000.
Помогите пожалуйста. очень срочно надо!

На pascal abc net
program test;
type realarray = array of real;
var
  step:real;
  a:realarray;
  i,n,s1,s2,s3,s4:integer;
begin
  write(Введите количество членов последовательности: );
  readln(n);
  step:=1/n;
  setlength(a,n);
  a[0]:=0;
  for i:=1 to n-1 do a[i]:=a[i-1]+step;
  for i:=0 to n-1 do begin
    if a[i]<0.25 then s1:=s1+1;
    if (a[i]>=0.25) and (a[i]<0.5) then s2:=s2+1;
    if (a[i]>=0.5) and (a[i]<0.75) then s3:=s3+1;
    if a[i]>=0.75 then s4:=s4+1;
  end;
  writeln(На промежутке [0,0.25)  -  ,s1);
  writeln(На промежутке [0.25,0.5)  -  ,s2);
  writeln(На промежутке [0.5,0.75)  -  ,s3);
  writeln(На промежутке [0.75,1)  -  ,s4);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку