1. Напишите программу, которая определяет сумму цифр 3-х числа. Например : 5+4div+8=17
2. Напишите программу , которая произведение чисел 3-х
( 548 ➡️ 160)
Помогите пожалуйста

//PascalABC.Net 3.0, сборка 1053
var
  n,s,p:integer;
begin
  Write(Введите натуральное трехзначное число: ); Read(n);
  s:=(n div 100)+((n div 10) mod 10)+(n mod 10);
  p:=(n div 100)*((n div 10) mod 10)*(n mod 10);
  Writeln(Сумма цифр числа равна ,s);
  Writeln(Произведение цифр числа равно ,p)
end.

Тестовое решение:
Введите натуральное трехзначное число: 548
Сумма цифр числа равна 17
Произведение цифр числа равно 160

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку