Даны натуральные числа n a1....an. составьте программу которая вычисляет сумму тех элементов последовательности а1...an которые кратны 3м

Const n=100;
var a: array [1..n] of integer;
    s,i: integer;
begin
  s:=0;
  for i:=1 to n do 
{ вывод массива на экран  }
  begin 
    a[i]:=Random(100);
    write(a[i], );
    if (i mod 10 =0) then writeln();
  end;
 { подсчет суммы элементов, кратных 3 }   
  for i:=1 to n do   
      if (a[i] mod 3 =0) then s:=s+a[i]; 
 writeln(сумма равна   ,s);
end.             


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку