Составьте программу , которая определяет, количество цифр 2 у числа, введенного с клавиатуры,
через While...
Я не могу составить именно тело цикла. Вот что есть
program Z_15;
VAR Num, F, F2 : longint;
var kn2 :byte;
begin
F:=0;
kN2:=0;
writeln(Enter Number);
writeln(P.S. Number > Zero);
readln(NUM);
While Num>0 do
begin
----------
----------
if F = 2 then
KN2:=KN2 + 1;
end;
Writeln(KN2 is =,KN2);
end.

Program Z_15;
VAR Num, F, F2 : longint;
var kn2 :byte;

begin
F:=0;
kN2:=0;
writeln(Enter Number);
writeln(P.S. Number > Zero);
readln(NUM);
While Num>0 do
begin
F:=num mod 10;
num:=num div 10;
if F = 2 then
KN2:=KN2 + 1;
end;
Writeln(KN2 is =,KN2);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку