Помогите пожалуйста! Срочно!
На шахматном поле стоят два коня(черный и белый). Выяснить, бьет ли один конь другого. Написать программу.
P.S. Может быть задача элементарная, но я с программированием не дружу. Заранее спасибо

Вот пример программы. Вводятся числа x1, y1 - координаты белого коня, x2, y2 - координаты черного коня.
var x1, y1, x2, y2: byte;
begin
  read(x1, y1, x2, y2);
  if (abs ((x1 - x2) * (y1 - y2)) = 2)
    then write(YES)
    else write(NO)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку