Составить программу на паскале.
Дано натуральное число:
а) Найти количество четных цифр;
б) Верно ли, что цифра а встречается в числе более двух раз а вводится с клавиатуры.
Var a,b,c,c1,a1:integer;
begin
write(введите число => );
readln(a);
write(введите число а => );
readln(a1);
c:=0;
c1:=0;
while (a<>0) do begin
b:=a mod 10;
a:=a div 10;
if (b mod 2 =0) then c:=c+1;
if (b=a1) then c1:=c1+1;
end;
writeln(количество чётных цифр =>, c);
if (c1>2) then writeln(а встречается в числе больше двух раз);
end.
Оцени ответ
