Напишите программу, которая по введенному не более чем 4-х значному числу K будет выдавать сумму его цифр.
На входе K(0<=k<=9999).



var
k,s: integer;
begin
Writeln(Введите число K:);
Readln(k);
if (k<=9999) and(k>=0) then
begin
if k div 1000 <>0 then
 s:= (k mod 10) + (k div 1000) + ((k  div 100)mod 10) + (k div 10)mod 10;
if (k div 1000 = 0)  and (k div 100 <> 0) then
s:=(k mod 10) +( k  div 100) + (k div 10)mod 10;
if (k div 100 = 0)  and (k div 10 <> 0) then
s:= (k mod 10) + (k div 10); 
if (k div 10 = 0)  and (k mod 10 <> 0) then
s:= k;Writeln(Сумма цифр = , s);
end;end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку