Для выбора водящего в детской игре N человек становятся в круг,после чего произносится считалка.На первом слове считалки указывается на первого человека в кругу,на втором слове - на второго человека и т.д. После N-го человека снова идет первый человек (все люди в кругу пронумерованы числами от 1 до N,круг зацикливается,после человека с номером N идет человек с номер 1)
Всего в считалке M слов.Определите на какого человека придется последнее слово считалки.
Программа получает на вход два целых положительных числа.Первое число N-количество людей в кругу.Второе число M - количество слов в считалке.Оба числа не превосходит 10^9.
Программа должна вывести одно число от 1 до N - номер человека в кругу на которого придется последнее слово считалки
Ввод Вывод
10 5
15

123456789101112131415161718192021222324import java.io.*;public class Main {public static void main(String[] args)throws Exception {        DataInputStream in = new        DataInputStream(System.in);        long n, m, result=0;        n = Integer.parseInt(in.readLine());        m = Integer.parseInt(in.readLine());        if(m<=n){            result  = m;        }else{        while(m>n){            m=m-n;            result = m;            if(result<0){                result *=-1;            }        }        }               System.out.println(result);}}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×