Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если программа предложила большее число то пользователь нажимает < если программа предложила меньшее число то пользователь нажимает > а если угадала то =
Тема циклы
var min,max,n:integer;
c:string;
Begin
min:=1;
max:=1000;
repeat
n:=(max+min) div 2;
writeln(n);
read(c);
case c of
">": min:=n+1;
"<": max:=n-1;
end
until (c="=");
End.
Оцени ответ
