Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел.Используйте оператор repeat. Решить в паскале.
Предполагается, что будет введено минимум одно значение.
var
max,a : integer;
begin
readln(a);
max := a;
repeat
readln(a);
if (a > max) and (a <> 0) then
max := a;
until a = 0;
writeln(max);
readln;
end.
P.S. Если понравилось решение не забудь отметить как лучшше. ;)
Оцени ответ
