Составить программу вставки в массив A(N) первого элемента, равного 7

Program R1;
Var a:array[1..100] of integer;
i,n:integer;
begin
assign(input,input.txt);
reset(input);
assign(output,output.txt);
rewrite(output);
readln(n);
for i:=1 to n do read(a[i]);
for i:=n+1 downto 2 do
a[i]:=a[i-1] ;
a[1]:=7 ;

for i:=1 to n+1 do write(a[i], );
close(input);
close(output);
end.

 например

ввод

4

1 2 3 4 

 вывод 

7 1 2 3 4

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку