Написать программу в паскале
Написать программу для решения следующей задачи: упорядочить по возрастанию элементы каждой строки матрицы А(10,8) и вывести ее в виде таблицы.
var a:array [1..10,1..8] of longint;
i,j,k,x:longint;
beginfor i:=1 to 10 do
for j:=1 to 8 do a[i,j]:=random(20)-10;
writeln ( Массив до изминений: );
for i:=1 to 10 do
begin
for j:=1 to 8 do write ( a[i,j], );
writeln;
end;
for i:=1 to 10 do
begin
for j:=1 to 8-1 do
for k:=j+1 to 8 do
if a[i,j]>a[i,k] then
begin
x:=a[i,j];
a[i,j]:=a[i,k];
a[i,k]:=x;
end;
end;
writeln ( Массив после изминений: );
for i:=1 to 10 do
begin
for j:=1 to 8 do write ( a[i,j], );
writeln;
end;
end.
Оцени ответ
