Помогите,пожалуйста
необходимо написать программу в Паскале
Вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива.
Var
a:array[1..10] of integer;
n,i:integer;
begin
readln(n);
for i:=1 to 10 do begin
a[i]:=random(-10,10);
if (a[i] < 0) and (i > 1) then begin
if a[i-1] > 0 then a[i-1]:=n;
end;
if (a[i] < 0) and (i = 1) then write(n:3);
end;
for i:=1 to 10 do write(a[i]:3);
end.
Оцени ответ
